18.04.2013 | Рубрика: Новости Apple | Автор: Всеволод | Просмотров: 1084

Apple выпустила серию обновлений для Safari и Java, чтобы снизить проблемы с безопасностью. Для OS X Mountain Lion и Lion браузер Safari получил версию 6.0.4, а для OS X Snow Leopard - 5.1.9. Обновления могут быть получены автоматически через механизм обновления ПО на OS X. Они добавляют новые специальные параметры для включения Java Plug-In на веб-сайт на основе сайта, причем с четырьмя настройками на выбор.

Apple предпочитает принудительно отключать Java Plug-In. Но теперь управление для Java веб-модулей стало в большей мере зависеть от пользователей, причем не только с возможностью выбора «активен-не активен». Совсем обойтись без Java нельзя, так как некоторые апплеты и, скажем, казуальные игры, требуют их работы. Но в иных случаях функциональность файла от них не зависит, так что можно без проблем отказаться от них в пользу повышения безопасности.

При обнаружении использования Java на странице, браузер спрашивает пользователя, хочет ли он их активировать. Таким образом для пользователей будет более удобным составление так называемого «белого списка» надежных сайтов, на которых Java будет запускаться всегда, на других он будет всегда блокироваться, ну а на незнакомых будет спрашивать разрешение, которое может быть дано единоразово.

Дополнительно была повышена производительность и исправлена пара ошибок. Также были обновлены драйверы для принтеров и сканеров НР, Саnon и Epson. Теперь поддерживаются новые модели, изменены драйверы для некоторых существующих моделей, улучшена совместимость с Mac Snow Leopard и более поздними версиями OS.

Кроме этого Apple выпустила обновленные версии Java 6. Это будет Java для OS X 2013-003 для пользователей OS X Mountain Lion и Lion и Java для Mac OS X 10.6 обновление 15 для пользователей OS X Snow Leopard. При этом любые установки Java SE 6 обновляются до 1.6.0_45 версии. Если в системе не было установлено Java для OS X 2012-006, то обновление будет отключить Java SE 6 веб-модули полностью (пользователи по-прежнему имеют возможность обновиться до последней версии Java SE 7, или установить обновление 2012-006). Можно также установить последнюю версию Java SE 7 напрямую через сайт Oracle, однако тогда Apple не отвечает за угрозы безопасности.


Метки: , ,

Добавить комментарий

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

Получить рекомендации
Введите ваш номер телефона